
 

optris PIconnect 
 

    

Oprogramowanie kamery termograficznej 

 

 
 

 

 

 

 

 

 

 

 

Instrukcja obsługi 
 

 



TEST-THERM Sp. z o.o., ul.Friedleina 4-6, 30-009 Kraków 

optris PIConnect – PL2011-02-A 

2 

Spis treścSpis treścSpis treścSpis treściiii    
 

1. WITAMY! .............................................................................................................................. 4 

2. NOTY PRAWNE ................................................................................................................... 5 

3. PIERWSZE KROKI ............................................................................................................... 6 

3.1. Instalacja programu .................................................................................................... 6 

3.2. Wybór kamery ............................................................................................................. 7 

3.3. Wybór języka .............................................................................................................. 7 

3.4. Okno programu (przykład) .......................................................................................... 8 

3.5. Menu i pasek narzędziowy (ikony) ............................................................................ 10 

3.5.1. Menu ............................................................................................................... 10 

3.5.1. Pasek narzędziowy (ikony) .............................................................................. 11 

4. KONFIGURACJA PROGRAMU .......................................................................................... 12 

4.1. Ustawienia ogólne..................................................................................................... 12 

4.1.1. Palety barw ...................................................................................................... 12 

4.1.2. Jednostka temperatury .................................................................................... 14 

4.1.3. Zakres temperatury palety barwnej .................................................................. 14 

4.1.4. Wyświetlana liczba ramek ................................................................................ 14 

4.1.5. Zmiana paska tytułowego ................................................................................ 16 

4.1.6. Optymalizacja programu .................................................................................. 16 

4.2. Szablon programu..................................................................................................... 17 

4.2.1. Wyświetlane okna ............................................................................................ 17 

4.2.2. Widok pasków.................................................................................................. 18 

4.2.3. Informacje na obrazie ...................................................................................... 18 

4.2.4. Temperatury na wyświetlaczach cyfrowych ...................................................... 19 

4.2.5. Zarządzanie szablonami .................................................................................. 20 

4.2.6. Assign / remove layouts ................................................................................... 21 

2.2.6. Informacje dodatkowe ...................................................................................... 21 

4.3. Organizowanie obrazu termicznego .......................................................................... 22 

4.3.1. Odbicie lustrzane obrazu ................................................................................. 22 

4.3.2. Obrót obrazu .................................................................................................... 22 

4.3.3. Powiększanie obszarów wyświetlanego obrazu ............................................... 22 

4.4. Konfiguracja kamery ................................................................................................. 24 

4.4.1. Pliki kalibracyjne .............................................................................................. 24 

4.4.2. Korekcja kalibracji kamery ............................................................................... 24 

4.4.3. Emisyjność, przepuszczalność, temperatura otoczenia .................................... 25 

4.4.4. Temperatura wzorcowa ................................................................................... 26 

4.4.5. Zmiana optyki .................................................................................................. 27 

4.4.6. Zmiana zakresu temperatury ........................................................................... 27 

4.5. Interfejsy kamery ...................................................................................................... 28 

4.5.1. Informacje ogólne ............................................................................................ 28 

4.5.2. Interfejs procesowy (PIF) ................................................................................. 29 

4.6. Interfejsy programowe .............................................................................................. 30 

4.6.1. Komunikacja międzyprocesowa (IPC) .............................................................. 30 

4.6.2. Port szeregowy ................................................................................................ 30 

4.7. Opcje startowe .......................................................................................................... 31 

5. PRZECHWYTYWANIE DANYCH ....................................................................................... 32 

5.1. Otwieranie plików ...................................................................................................... 32 

5.2. Odtwarzanie plików ................................................................................................... 32 

5.2.1. Panel sterujący ................................................................................................ 32 



Tel.: 12 632 1301, 12 632 6188, Fax: 12 632 1037, e-mail: office@test-therm.pl 

optris PIConnect – PL2011-02-A 

3    

5.2.2. Opcje odtwarzania ........................................................................................... 32 

5.3. Edycja sekwencji wideo ............................................................................................ 33 

5.4. Zapisywanie plików ................................................................................................... 34 

5.4.1. Ustawianie częstotliwości ramki podczas zapisu .............................................. 34 

5.4.2. Ustawianie trybów rejestracji............................................................................ 35 

5.4.3. Tymczasowy plik rejestracji ............................................................................. 36 

5.4.4. Zapis sekwencji radiometrycznych lub AVI ...................................................... 36 

5.4.5. Zapis danych jako radiometrycznego zrzutu obrazu lub pliku tekstowego ........ 37 

5.4.6. Zapis pliku tekstowego czasowego przebiegu temperatury .............................. 39 

5.4.7. Położenie i szablony nazw plików wyzwalanych rejestracji .............................. 39 

5.4.8. Display of snapshots in a separate window ...................................................... 40 

5.4.9. Zapis obrazów lub zrzutów ekranu do schowka ............................................... 40 

6. PRZETWARZANIE DANYCH ............................................................................................. 42 

6.1. Obszary pomiarowe .................................................................................................. 42 

6.1.1. Ustawienia ogólne ........................................................................................... 42 

6.1.2. Wykluczanie obszarów punktów gorących i zimnych ....................................... 45 

6.1.3. Indywidualne wartości emisyjności obszarów pomiarowych ............................. 46 

6.2. Profil temperatury ..................................................................................................... 47 

6.3. Wykres czasowego przebiegu temperatury ............................................................... 50 

6.3.1. Ustawienia ogólne ........................................................................................... 50 

6.3.2. Skalowanie osi wykresu ................................................................................... 51 

6.4. Histogram ................................................................................................................. 53 

6.5. Rozszerzone kolory pomiarowe ................................................................................ 54 

6.6. Odejmowanie obrazów ............................................................................................. 55 

6.7. Względne wartości ektremalne ................................................................................. 56 

6.8. Alarmy ...................................................................................................................... 57 

7. TRYB SKANERA LINIOWEGO .......................................................................................... 60 

7.1. Informacje ogólne ..................................................................................................... 60 

7.2. Ustawienia podstawowe ........................................................................................... 61 

7.2.1. Menu konfiguracji skanera liniowego ............................................................... 61 

7.2.2. Wybór szablonu ............................................................................................... 61 

7.2.3. Obrót obrazu.................................................................................................... 61 

7.2.4. Włączanie skanera liniowego ........................................................................... 62 

7.2.5. Pozycjonowanie linii (tryb podglądu) ................................................................ 62 

7.2.6. Konfiguracja szablonu w trybie podglądu ......................................................... 63 

7.3. Przetwarzanie skanowanych danych ........................................................................ 64 

7.3.1. Widok skanera liniowego ................................................................................. 64 

7.3.2. Wyzwalane wyświetlanie linii ........................................................................... 65 

7.3.3. Konfiguracja zrzutów obrazu ............................................................................ 67 

8. INFORMACJE DODATKOWE ............................................................................................ 68 

8.1. Włączanie komunikatów ........................................................................................... 68 

8.2. Wymagania systemowe ............................................................................................ 69 

8.3. O programie.............................................................................................................. 69 

8.4. Przegląd skrótów klawiaturowych ............................................................................. 70 

 



TEST-THERM Sp. z o.o., ul.Friedleina 4-6, 30-009 Kraków 

optris PIConnect – PL2011-02-A 

4 

1. WITAMY! 

Dziękujemy za wybór oprogramowania optris PI Connect! 

 

Kamera optris PI wyznacza temperaturę powierzchni w oparciu o ilość 
energii promieniowania podczerwonego emitowanego przez obiekt. 
Dwuwymiarowa matryca FPA pozwala na pomiar temperatury obrazu o 
rozdzielczości 160x120 pikseli i wyświetlanie go przy pomocy 
standaryzowanych palet. Radiometryczne przetwarzanie danych obrazu 
pozwala użytkownikowi na komfortową analizę szczegółową za pomocą 
oprogramowania PI Connect. 

Główne cechy programu PI Connect: 

� Wyświetlanie obrazu w czasie 
rzeczywistym (120Hz) z całą 
gamą funkcji pomiarowych 

� Funkcje rejestracji (film wideo, 
radiometryczny film wideo, zrzuty 
obrazu) 

� Analiza i obróbka obrazów 
termicznych / plików wideo 

� Kompletna konfiguracja kamery i 
jej zdalne sterowanie 
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Optris GmbH 

Ferdinand-Buisson-Str. 14 

D – 13127 Berlin 

GERMANY 

 

Phone: +49-30-500 197-0 

Fax: +49-30-500 197-10 

 

E-mail: info@optris.de 

2. NOTY PRAWNE  

Wszystkie produkty firmy Optris GmbH są 
objęte gwarancją od wad materiałowych i 
produkcyjnych przez okres dwóch (2) lat 
od daty dostawy, pod warunkiem że takie 
produkty są normalnie przechowywane, 
użytkowane i obsługiwane, w zgodzie z 
instrukcją obsługi Optris GmbH instrukcji. 
Niniejsza gwarancja traci ważność w 
przypadku niewłaściwego wykorzystania 
wszystkich dostarczonych elementów. 

Wszystkie produkty nie wyprodukowane 
przez Optris GmbH zawarte w systemach 
dostarczonych przez Optris GmbH do nabywcy, posiadają gwarancję tylko 
odpowiednich dostawców i Optris GmbH nie ponosi odpowiedzialności za 
takie produkty.  

Optris nie ponosi odpowiedzialności za wykorzystanie oprogramowania 
optris PI Connect w tym rejestracji danych. Optris nie gwarantuje 
bezbłędnego działania oprogramowania na każdym sprzęcie i systemiem 
operacyjnym. 

Gwarancja nie obejmuje ewentualnych zmian jakości, błędów podczas 
używania oprogramowania, wad powstałych w czasie pracy lub 
niedostosowania do określonych zastosowań. Użytkownik ponosi 
odpowiedzialność za wady lub braki przetwarzania danych, podczas 
użytkowania oprogramowania.   

Optris GmbH nie ponosi innych zobowiązań dotyczących zakresu dostaw 
poza wymienionymi powyżej. Optris nie ponosi odpowiedzialności za 
jakiekolwiek straty finansowe lub roszczenia o odszkodowanie, utratę 
oprogramowania, utratę danych, dodatkowe koszty oprogramowania 
zastępczego, roszczenia osób trzecich oraz innych powstałych kosztów 
awarii i niedoborów. 

Oprogramowanie Optris jest chronione prawami autorskimi i nie może być 
modyfikowane ani odsprzedawane osobom trzecim. 

 

Uwaga!  
Przed rozpoczęciem eksploatacji urządzenia przeczytać starannie 
instrukcję obsługi. Producent zastrzega sobie prawo do zmiany 
opisywanych tutaj danych technicznych bez uprzedzenia, w razie 
technicznego rozwoju produktu. 
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3. PIERWSZE KROKI 

3.1. Instalacja programu 

Najpierw należy zainstalować z dostarczonej płyty CD-ROM program PI 
Connect. Płyta CD-ROM zawiera oprogramowanie, dane kalibracyjne 
kamery oraz pliki przykładowe. Wszystkie one zostaną zainstalowane 
automatycznie. 

 

 

Uwaga!  
Przed zainstalowaniem nowej wersji oprogramowania proszę 
odinstalować starą wersję PI Connect. Można to zrobić za pomocą 
ikony Uninstall PI Connect znajdującej się w folderze programu w 
menu Start. 

 

Umieścić płytę instalacyjną CD-ROM w odpowiednim napędzie optycznym 
komputera. Jeśli funkcja systemowa autorun jest aktywna program 
instalacyjny uruchomi się automatycznie. Jeśli nie, należy uruchomić 
program setup.exe bezpośrednio z płyty CD-ROM. Postępować zgodnie z 
instrukcjami instalatora aż program zostanie zainstalowany. 

Instalator umieści ikony skrótów do programu na pulpicie systemowym oraz 
w menu Start: [Start] > Programy > Optris GmbH > PI Connect. 

 

Teraz można podłączyć kamerę do portu 
USB 2.0 komputera. Po uruchomieniu 
programu, na ekranie monitora powinien 
się ukazać obraz transmitowany na żywo z 
kamery. 

 

Ostrość obrazu można wyregulować 
kręcąc zewnętrznym pierścieniem 
obiektywu kamery. 
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3.2. Wybór kamery 

W przypadku jednoczesnego używania więcej niż jednej kamery PI (np. 
poprzez hub USB) należy wybrać odpowiedni egzemplarz z lisy znajdującej 
się w menu Devices.  

3.3. Wybór języka 

Za pomocą menu Tools > Language można 
wybrać z listy wersję językową interfejsu 
programu.  

 

 

 

 

 

 

 

 

Uwaga! 
Jeśli pożądany język nie występuje na liście, możliwe jest 
dokonanie samodzielnego tłumaczenia za pomocą specjalnego 
narzędzia programistycznego znajdującego się na dostarczonej 
płycie CD-ROM. 
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3.4. Okno programu (przykład) 
 

  

1 

2 

2 

 

3 4 

4 

5 

6 

4 

7 

8 

9 10 
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1 Obraz IR z kamery 

2 Profil temperatury: pokazuje przebieg temperatury wzdłuż 
maksymalnie 2 odcinków o dowolnym rozmiarze i położeniu na 
obrazie. 

3 Paleta barw: wskazuje przyporządkowanie barw do wartości 
temperatury. 

4 Temperatura mierzonego obszaru: wskazanie wartości  temperatury 
odpowiedniego obiektu, np. średniej temperatury prostokąta. Wartość 
jest wskazywana na obrazie termicznym oraz na wyświetlaczach 
cyfrowych. 

5 Wyświetlacze kontrolne: wskazują wszystkie wartości temperatury 
zdefiniowanych obiektów takich jak gorące punkty, zimne punkty, 
temperatura kursora, temperatura wewnętrzna i temperatura matrycy. 

6 Ustawienia alarmu: bargraf pokazujący zdefiniowane progi 
temperatury alarmu dolnego (niebieska strzałka) oraz górnego 
(czerwona strzałka). Kolor liczb na wyświetlaczach kontrolnych 
zmienia się na czerwony (gdy temperatura wzrasta powyżej górnej 
granicy alarmu) lub niebieski (gdy temperatura spada poniżej dolnego 
progu alarmowego). 

7 Histogram: pokazuje rozkład statystyczny wartości temperatury na 
określonym obszarze. 

8 Automatyczne / ręczne skalowanie palety barw (wyświetlanego 
zakresu temperatury): Man., </> (min, max), 1σ: 1 Sigma, 3σ: 3 
Sigma 

9 Ikony szybkiego dostępu do funkcji odejmowania obrazów 

10 Ikona pozwalająca na szybkie przełączanie palet barwnych 
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3.5. Menu i pasek narzędziowy (ikony) 

3.5.1. Menu 

Za pomocą menu można skonfigurować wszystkie ustawienia programu. 
Każda funkcja będzie szczegółowo objaśniona w kolejnych rozdziałach 
podręcznika: 

 

 

File Otwieranie, zapisywanie i odtwarzanie plików.  

Edit Edycja sekwencji i szablonów. 

View Wyświetlanie i wygaszanie różnych funkcji programu 

Devices Wybór kamery i autokalibracja 

Tools Dodatkowe ustawienia parametrów kamery i programu 

Help Informacja o programie 
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3.5.1. Pasek narzędziowy (ikony) 

Najważniejsze funkcje oprogramowania można włączać bezpośrednio za 
pomocą paska narzędziowego. Pasek narzędziowy można przedefiniować 

stosownie do własnych potrzeb (patrz rozdział 4.2.2). Dostępne są 

następujące ikony: 

 Konfiguracja  Pełny ekran  
Zamknij wszystkie 
narzędzia 

 Otwórz  Poprzednia paleta  
Przełączanie min, 
średnia, max 

 Zapisz  Kolejna paleta  Historia zrzutów 

 Odtwórz  Pasek palety  
Odejmowanie 
obrazów 

 Pauza  Histogram  
Odejmowanie 
obrazów z pliku 

 Stop  
Profil temperatury 
(poziomy)  

Włączenie 
skanera liniowego 

 Nagrywanie  
Profil temperatury 
(pionowy)  

Widok skanera � 
Podgląd 

 
Kopiuj zrzut obrazu 
do schowka  

Wykres przebiegu 
czasowego  

Konfiguracja 
skanera liniowego 

 Zapisz zrzut obrazu  

Wyświetlacz cyfrowy 
(główny obszar 
pomiarowy) 

 
Flaga 

 
Kopiuj zrzut obrazu 
schowka  

Wyświetlacz cyfrowy 
(kursor myszy)  

Alarm 

 Zapisz zrzut obrazu  
Grupa wyświetlaczy 
cyfrowych 
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4. KONFIGURACJA PROGRAMU 

4.1. Ustawienia ogólne 

Za pomocą menu Tools > Configuration > General można konfigurować 
wszystkie opisywane tutaj funkcje (oprócz palet barwnych). 

4.1.1. Palety barw 

W menu Tools > Configuration > Measuring 
colors i Standard palette można wybierać spośród 
listy palet w celu osiągnięcia najlepszego wyglądu 
obrazu oraz informacji o temperaturze. 

 

 

Paletę można też wybierać za pomocą ikon paska 
narzędziowego albo za pomocą menu View > Shift 
palette. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Iron Hi 

Iron 

Blue Hi 

Alarm Red 
Rainbow 

Rainbow Hi 

Rainbow Medical 

Gray (czarny = zimny) 

Gray (biały = zimny) 

Alarm Green 

Alarm Blue 
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Przykłady różnych palet barwnych: 

 

 

 

 

 

 

 

 

Iron  Rainbow 

 

 

 

 

 

 

 

 

 

Rainbow Hi  Rainbow Medical 

 

 

 

 

 

 

 

 

 

Blue  Gray 
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4.1.2. Jednostka temperatury 

Temperatura może być wyświetlana w stopniach 
Celsjusza (°C) albo Fahrenheita (°F). 

 

 

4.1.3. Zakres temperatury palety barwnej 

Za pomocą ustawień Min i Max można przypisać 
kolory do wartości temperatury. 

 

 

Istnieją następujące możliwości: 

Manual Górna i dolna granica są ustalane indywidualnie. 

</> 
Oprogramowanie ciągle wyznacza górną i dolną granicę w 
oparciu o najcieplejszy i najchłodniejszy piksel obrazu. 

1 σ 

Wyznaczana jest średnia wartość temperatury wszystkich pikseli 
obrazu. Zakres temperatury jest oparty o wartość średnią i 
szerokość jednego odchylenia standardowego (1 sigma) ustalają 
granice zakresu palety barw. 

3 σ 

Wyznaczana jest średnia wartość temperatury wszystkich pikseli 
obrazu. Zakres temperatury jest oparty o wartość średnią i 
szerokość trzech odchyleń standardowych (3 sigma) ustalają 
granice zakresu palety barw. 

 

4.1.4. Wyświetlana liczba ramek 

Opcja Reduce displayed frames 
określa częstotliwość ramki 
używaną podczas wyświetlania 
obrazu. Typowo, parametr jest 
podawany w Hz (obrazach na 
sekundę). Max. częstotliwość ramki 
kamery wynosi 120 Hz.  

Kamera dostarcza programowi przez cały czas obrazy. Zredukowanie 
częstotliwości ramki oznacza, że niektóre obrazy nie będą rozpatrywane. 
Wybrany algorytm definiuje te które będą lub nie będą wyświetlane: 
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Off Częstotliwość wyświetlania wynosi 120Hz. 

Skipping 
Pozostałe obrazy będą pomijane z określoną częstotliwością 
ramki, co oznacza, że dla 10Hz będzie wyświetlany co 12-ty 
obraz. 

Average 
Obrazy będą uśredniane ze zdefiniowaną częstotliwością 
ramki, co oznacza, że dla 10Hz 12 obrazów utworzy jeden 
obraz uśredniony. 

Minimum 
Przykładowo przy 10Hz 12 pojedynczych obrazów utworzy 
jeden obraz składający się z pikseli o najniższej 
temperaturze. 

Maximum 
Przykładowo przy 10Hz 12 pojedynczych obrazów utworzy 
jeden obraz składający się z pikseli o najwyższej 
temperaturze. 

Ext. 
Averaging 

Obrazy będą uśredniane ze zdefiniowaną częstotliwością 
ramki jak również czasem uśredniania co oznacza, że 
przy10Hz i 50% czasu ramki 50% z 12 obrazów (czyli 6 
obrazów) utworzy nowy uśredniony obraz. 

 

 

Uwaga! 
Zredukowana liczba ramek oznacza mniejsze obciążenie komputera 
jeśli chodzi o przetwarzanie danych. Dlatego należy dostosować 
wyświetlaną liczbę ramek stosownie do zastosowania oraz 
możliwości sprzętowych komputera. 
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4.1.5. Zmiana paska tytułowego 

Pasek tytułowy programu 
może posiadać własne 
ustawienia.  

Ustawienie Default powoduje 
wyświetlanie standardowej 
nazwy programu „Optris PI Connect“. Wybranie ustawienia User defined 
pozwala na wpisanie dowolnej nazwy w polu poniżej. Opcja Instance name 
jest ważna w przypadku uruchomienia kilku kamer i programu na jednym 
komputerze. Opcja Revision name blokuje wyświetlanie wersji programu na 
pasku tytułowym. 

4.1.6. Optymalizacja programu 

Wyświetlanie obrazu termicznego w 
oknie głównym programu może być 
dostosowane do możliwości 
komputera. Przy wykorzystywaniu 
wolnego komputera zaleca się zaznaczenie opcji Performance i wyłączenie 
wszystkich pozostałych (ekran będzie powiększony ze 160x120 pikseli do  
320x240 pikseli). Wybranie opcji Quality i High-speed temperature 
powoduje powiększenie obrazu ze 160x120 pikseli na 640x480 pikseli. 

Po zaznaczeniu opcji Keep aspect ratio będą 
zachowywane proporcje obrazu.  

Opcja Prevent screensaver blokuje działanie 
wygaszacza ekranu w komputerze. 
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4.2. Szablon programu 

4.2.1. Wyświetlane okna 

Można indywidualnie wybierać wyświetlane 
okna i łatwo zmieniać ich położenie na pulpicie 
(przeciągnij i upuść). Aby dodać okno należy 
wykorzystać pozycję menu View > Windows. 

Z jednej strony okna można rozmieszczać 
oddzielnie na ekranie. Z drugiej strony okna 
można umieszczać w stałym miejscu 
programu. Położenie można określić za 
pomocą pola pozycjonującego (kursor myszy 
ponad strzałkami „powyżej“, „poniżej“, „po 
prawej“, „po lewej“). 

Gdy jedno okno jest wleczone nad inne (kursor myszy musi być 
umieszczony na pasku tytułowym) obydwa zostaną połączone. Można się 
przełączać między nimi za pomocą przewidzianej do tego zakładki.  

 

 

 

 

 

 

 

 

 

 

Oddzielne okna albo okna podzielone z polami pozycjonującymi do 
indywidualnego umieszczenia  w programie.  
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4.2.2. Widok pasków 

Każdy z wyświetlanych elementów programu 
można indywidualnie włączyć lub ukryć w  oknie 
programu. 

Istnieje też możliwość pokazania lub ukrycia 
wszystkich pasków (Show all bars / Hide all 
bars) jednym kliknięciem. 

 

 

 

 

 

 

 

Uwaga! 
Wszystkie ikony pokazane na paku narzędziowym można 
indywidualnie dobierać za pomocą opcji Customize tool bar/ 
(patrz też rozdział 3.5.1).  

 

 

 

 

 

 

4.2.3. Informacje na obrazie 

Za pomocą menu View and Image 
Information można określić, która 
informacja ma być wyświetlana na obrazie 
termicznym. 

 

Za pomocą opcji Reference bar można 
ustalić położenie skali temperatury w 
oknie obrazu termicznego. 
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Pozycja menu Use contrast color może być wykorzystywana do 
wyróżniania określonych informacji na obrazie termicznym. 

 

 

 

 

 

 

 

 

 

Wyświetlanie obrazu bez i z  kontrastowymi barwami 

 

4.2.4. Temperatury na wyświetlaczach cyfrowych 

Opcja menu View > Digital display group temperatures pozwala na 
zdefiniowanie które wyświetlacze będą widoczne w oknie programu 
Temperatures (patrz rozdział 4.2.1). Wskazywane predefiniowane wartości 
mogą być też wyświetlane na wykresie przebiegu temperatury (patrz rozdział 
6.3).  

Dodatkowo, konfiguracja alarmu może być oparta na 

tych wskaźnikach (patrz rozdział 6.8)  
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4.2.5. Zarządzanie szablonami 

Za pomocą opcji menu View > Layouts można 
zarządzać gotowymi lub własnymi szablonami 
programu. W razie potrzeby zastosowania 
alternatywnego szablonu należy go uaktywnić 
za pomocą opcji Load layout. Można też 
zapisywać własne szablony pod dowolnymi 
nazwami (Save layout).  

 

 

 

Uwaga! 
Przed kliknięciem opcji Save layout należy dodać nową nazwę 
szablonu w przewidzianym do tego polu.  
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4.2.6. Assign / remove layouts 

Za pomocą opcji menu Edit > Assign layout to current file 
można zapisywać pliki z ustawieniami nowego szablonu. 

Za pomocą opcji Remove layout from current file można 
skonfigurować plik w ten sposób, żeby nie był skojarzony z 
żadnym szablonem. Po jego ponownym odtworzeniu zostanie użyty szablon 
ostatnio otwieranego pliku.  

 

 

Uwaga! 
Aby zatwierdzić wszystkie objaśnione powyżej zmiany należy 
zawsze zapisać plik. Należy w tym celu wykorzystać opcję menu 
File > Save albo ikonę na pasku narzędziowym. 

 

2.2.6. Informacje dodatkowe 

Niezależnie od tego czy na komputerze są otwarte inne programy, PI 
Connect może zawsze być utrzymywany na wierzchu. Aby włączyć tę 
funkcję należy użyć opcji View > Always on top. Wszystkie inne aplikacje 
będą odtąd pracować w tle. 

 

Obraz termiczny okna głównego może być wyświetlany w trybie 
pełnoekranowym. W tym celu należy wykorzystać polecenie menu 
File > Full screen albo ikonę paska narzędziowego do zmiany 
wielkości obrazu. 
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4.3. Organizowanie obrazu termicznego 

Obraz termiczny w oknie głównym programu może być wyświetlany na różne 
sposoby za pomocą menu Tools > Configuration > IR Image arranging. 

 

4.3.1. Odbicie lustrzane obrazu  

Czasem zależnie od pozycji 
montażowej kamery PI, jest użyteczne 
dokonanie lustrzanego odbicia obrazu 
w poziomie (Horizontal) lub pionie 
(Vertical). Obraz można skonfigurować za pomocą menu opisanego 
powyżej albo Tools > Mirror. 

 

4.3.2. Obrót obrazu  

Za pomocą opcji Rotate można obracać 
obraz termiczny o zdefiniowane kąty. 
Alternatywnie, można dokonać obrotu 
ręcznego o dowolny kąt za pomocą 
opcji User defined angle. Poniżej 
zostanie przestawiony nowy rozmiar 
obrazu: Resulting size. 

 

 

 

 

4.3.3. Powiększanie obszarów wyświetlanego obrazu  

Za pomocą opcji Zoom można 
powiększyć zdefiniowany obszar 
obrazu w oknie głównym. Ustawienia 
można aktywować klikając opcję Zoom 
enabled. Wynikowe rozmiary obrazu 
będą widoczne poniżej: Resulting 
size. 
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Obrót i powiększanie zdefiniowanego obszaru pomiarowego 
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4.4. Konfiguracja kamery 

4.4.1. Pliki kalibracyjne 

Menu Tools > Extended > Reimport calibration files pozwala na 
wczytanie danych kalibracyjnych dla aktualnie podłączonej kamery PI. 

 

4.4.2. Korekcja kalibracji kamery 

Z uwagi na dryft termiczny bolometrów, wszystkie kamery IR 
wymagają dokonywania co kilka minut korekcji offsetu. Korekcja ta 
jest wykonywana przez ustawianie za pomocą silniczka 
poczernionego kawałka metalu (tzw. flagi) naprzeciw detektora obrazu. W 
ten sposób każdy element obrazu jest wystawiony na działanie tej samej 
temperatury. Podczas korekcji offsetu kamera nie dokonuje pomiaru 
(autokalibracja trwa 250ms). W celu zminimalizowania tego zakłócenia 
pomiaru korekcja offsetu może być inicjowana ręcznie albo zewnętrznym 
sygnałem sterującym w odpowiednim momencie czasu. 

Za pomocą opcji menu Devices > Refresh 
flag albo ikony paska narzędziowego flaga 
(migawka) może być odświeżana ręcznie. 

Może być też ustawiona automatyczna 
korekcja kamery przez zdefiniowanie 
minimalnego i/lub maksymalnego odstępu 
czasu za pomocą menu Tools > 
Configuration > Device. Opcje Flag 
automatic oraz Min. Interval powodują, że 
flaga nie zostanie użyta przez określony okres czasu nawet gdyby to było 
wymagane przez kamerę. Jeśli zostanie zdefiniowany parametr Max. 
Interval flaga zawsze będzie użyta po określonym okresie czasu, nawet 
gdyby to nie było wymagane przez kamerę. 

Opcja Use flag znajdująca się w sekcji Flag operation while recording 
powoduje używanie flagi nawet podczas dokonywania nagrywania obrazu. 
Jeśli zostanie zaznaczona opcja Avoid flag kamera nie będzie dokonywać 
korekcji podczas nagrywania. Opcja Use flag while skipped frames jest 
właściwa dla wolnego nagrywania (częstotliwość ramki 3Hz lub mniej) 
ponieważ korekcja będzie dokonywana automatycznie pomiędzy kolejnymi 
nagrywanymi obrazami (czas korekcji ok. 250ms). 
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Uwaga! 
Działanie flagi w trybie korekcji ręcznej lub automatycznej nie 
będzie dostępne, gdy flaga jest sterowana sygnałem 
zewnętrznym, np. za pomocą wejścia interfejsu procesowego 

(patrz rozdział 4.5). 

 

 

Uwaga! 
Flaga może być używana w celu ochrony detektora przed 
potencjalnie niebezpiecznym promieniowaniem (np. laserowym). 

 

4.4.3. Emisyjność, przepuszczalność, temperatura otoczenia 

Za pomocą menu Tools > Configuration 
> Device można ustawić emisyjność 
Emissivity i przepuszczalność 
Transmissivity (kompensację okienka IR). 
Przepuszczalność dotyczy strat 
mierzonego promieniowania emitowanego 
przez powierzchnię obiektu podczas 
pomiaru przez odpowiednie okienko. 

Znajomość temperatury otoczenia 
Ambient temperature jest niezbędna dla prawidłowego pomiaru 
temperatury. Wartość temperatury otoczenia jest dostarczana domyślnie 
przez czujnik wewnątrz kamery. Alternatywnie, można wpisać ręcznie 
wartość temperatury. 

 

 

Uwaga! 
W przypadku gdy wartości emisyjności i/lub temperatury są 
kontrolowane przez interfejs procesowy (PIF) tutaj zdefiniowane 
wartości będą zignorowane (patrz rodział 4.5). Wskazanie wartości 
aktualnych będzie widoczne w pasku statusu. 
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4.4.4. Temperatura wzorcowa 

Detektor kamery posiada dryft 
termiczny, który musi być co 
jakiś czas korygowany przez 
autokalibrację. W zastosowa-
niach wymagających wysokiej 
dokładności, obraz termiczny 
może być korygowany ciągle 
przez określenie temperatury wzorcowej. Za pomocą menu Tools > 
Configuration > Device > Reference temperature można ustawić kilka 
opcji korekcji ręcznej lub automatycznej. 

 

Jeśli na obrazie termicznym występuje obszar posiadający stałą wartość 
temperatury (np. ciało doskonale czarne) opcję Source można zdefiniować 
jako Fixed value. Za pomocą opcji Compare with measuring area można 
wyznaczyć obszar o stałej temperaturze. Znaną wartość wzorcową można 
wpisać w polu Fixed value. Jeśli temperatura nieco się zmienia wewnątrz 
zdefiniowanego obszaru z powodu dryftu termicznego, cały obraz zostanie 
skorygowany przez stały współczynnik.  

Alternatywnie, korekcja może być dokonana za pomocą wartości 
zewnętrznej (np. podłączonego pirometru) poprzez wybranie interfejsu 
procesowego PIF in (patrz też rozdział 4.5). 

 

Istnieje kilka sposobów dostrojenia obrazu (Fitting mode) : 

Auto 
Program sam dobiera najlepszy sposób korekcji 
obrazu (offset lub wzmocnienie). 

Offset 
Ten sposób korekcji jest zalecany, gdy istnieje 
duża różnica temperatury między wartością 
wzorcową a wartościami na obrazie. 

Gain 
Ten sposób korekcji jest zalecany, gdy istnieje 
mała różnica temperatury między wartością 
wzorcową a wartościami na obrazie. 

 

Opcja Consider flag obniża wpływ korekcji kamery (wysokie skoki 
temperatury) przy wyświetlaniu temperatury wzorcowej. Zaleca się włączyć 
tę opcję. 
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4.4.5. Zmiana optyki 

Za pomocą menu Tools > 
Configuration > Device 
należy ustawiać konfigurację 
optyki kamery. Standardowo 
kamera może być dostarczana z obiektywami 23°, 6° lub 48°. Jeśli kamera 
zostanie zamówiona z kilkoma dodatkowymi obiektywami aktualnie używany 
obiektyw musi być określony za pomocą tego menu. 

 

Opcja Radial Distortion Correction pozwala na zmianę oryginalnego 
kształtu obrazu dostarczanego przez kamerę PI (korekcja zniekształceń 
baryłkowych). Jeśli kamera jest wyposażona w obiektyw 48° opcja jest 
włączana domyślnie, inne obiektywy nie wymagają korekcji.  

 

4.4.6. Zmiana zakresu temperatury 

Za pomocą opcji menu Tools > Configuration > 
Device można ustawić najbardziej odpowiedni dla 
danego zastosowania zakres temperatury. Kamera 
PI posiada 3 zakresy pomiarowe: 20°CV100°C, 
0°CV250°C oraz 150°CV900°C. 
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4.5. Interfejsy kamery 

4.5.1. Informacje ogólne 

Kamera PI jest wyposażona w interfejs procesowy (kabel zintegrowany z 
elektroniką i blokiem zacisków), który można zaprogramować za pomocą 
oprogramowania jako wejście analogowe (PIF in) i wejście cyfrowe (Dig In) w 
celu sterowania pracą kamery lub jako wyjście analogowe (PIF out)w celu 
sterowania procesem. Poziom sygnału wynosi zawsze 0V10V. Interfejs 
procesowy można aktywować wybierając spośród następujących opcji: 

 

PIF IN PIF OUT PIF (Digital input) 

Emisyjność Temperatura obszaru gł. Sterowanie flagą 

Temperatura otoczenia Temperatura wewnętrzna Wyzwalanie nagrywania 

Temperatura wzorcowa Status flagi Wyzwalanie zrzutów 

Sterowanie flagą Alarm Wyzwalanie skanera 

Wyzwalanie nagrywania     

Wyzwalanie zrzutów     

Wyzwalanie skanera   

 

 

Konfiguracja interfejsu procesowego (PIF) 
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4.5.2. Interfejs procesowy (PIF) 

Za pomocą menu Tools > 
Configuration > Device PIF można 
włączyć interfejs procesowy jako 
wejście (PIF in). Wartość 
emisyjności, temperatury otoczenia i 
temperatury wzorcowej można 
wyskalować sygnałem 0V10V. Dla 
innych opcji należy zdefiniować 
wartość napięcia progowego Threshold [V] – opcja jest aktywna gdy 
wartość napięcia przekracza ten próg. Po zaznaczeniu, wartość sygnału 
poniżej progu uaktywnia działanie. 

 

Za pomocą menu Tools > 
Configuration > Device PIF można 
włączyć interfejs procesowy jako 
wyjście (PIF out). Wybrany tryb 
pracy można skalować sygnałem 
0V10V albo stan za pomocą 
wartości progowych. 

 

Za pomocą Tools > Configuration > 
Device PIF można włączyć interfejs 
procesowy jako wejście cyfrowe 
(Digital input). Tryb można 
zdefiniować sygnałem napięciowym. 
Jeśli opcja Low active nie jest zaznaczona, wybrany tryb będzie 
aktywowany stanem wysokim. Po zaznaczeniu opcji Low active aktywacja 
będzie się odbywać stanem niskim.  

 

 

Uwaga! 
Interfejsów procesowych PIF in, PIF out oraz DIG in można używać 
jednocześnie. 
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4.6. Interfejsy programowe 

4.6.1. Komunikacja międzyprocesowa (IPC) 

Opcja menu Tools > Configuration > 
External Communication > 
Interprocess Communication (IPC) 
pozwala na wyprowadzenie informacji 
o kolorach obrazu, temperaturach lub 
wartościach ADU do innej aplikacji za pomocą bibliotek dynamicznych (DLL).  

 

4.6.2. Port szeregowy 

Komunikację za 
pomocą portu 
szeregowego 
można włączyć 
przy pomocy 
menu Tools > Configuration > External Communication > Comport 
menu. 

Wybrane informacje z kamery można uzyskać za pomocą określonego portu 
szeregowego. Prędkość transmisji można ustawić stosownie do potrzeb. 

 

 

Uwaga!  
Szczegóły dotyczące wykorzystania komunikacji międzyprocesowej 
oraz portu szeregowego znajdują się na dostarczonej płycie CD-
ROM. 
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4.7. Opcje startowe 

Program PI Connect może być uruchomiony z dodatkowymi 
parametrami startowymi za pomocą wiersza poleceń. 
Polecenie startowe można zmienić za pomocą ustawień 
ikony skrótu na pulpicie. Na końcu linii poleceń należy dodać 
spację a następnie wymagany parametr uruchomieniowy, np. 
"C:\Program\Optris GmbH\PI Connect\Imager.exe" /? 

 

Uruchamiając program za pomocą tak skonfigurowanej ikony skrótu uzyska 
się przegląd możliwych poleceń: 

 

 

 

 

Uwaga! 
Po uruchomieniu programu z parametrem /Invisible program 
można zamknąć jedynie przy pomocy Menedżera zadań i zakładki 
Procesy. 
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5. PRZECHWYTYWANIE DANYCH 

5.1. Otwieranie plików 

Za pomocą menu File > Open albo ikony na pasku narzędziowym 
można otwierać wszystkie pliki, które można przetwarzać w 
programie. 

 

 

Uwaga! 
Za pomocą menu File > Reopen można łatwo otworzyć 
przechwycone pliki jeśli jest włączona opcja opisana w rozdziale 
5.4.6.  

 

5.2. Odtwarzanie plików 

5.2.1. Panel sterujący 

W celu odtworzenia sekwencji 
wideo można wykorzystywać 
różne opcje z menu File lub 
panel sterujący. Panel sterujący zawiera polecenia: 

 

 Początek    Koniec 

 Przewiń   Odtwarzanie 

 Poprzedni obraz   Pauza 

 Następny obraz   Odtwarzanie w pętli 

 Do przodu   Odtwarzanie zaznaczenia 

 

5.2.2. Opcje odtwarzania 

Za pomocą menu Tools > 
Configuration > Playing > 
Playing options można 
zmodyfikować szybkość 
odtwarzania 
zarejestrowanych sekwencji 
wideo. Ta funkcja pozwala przykładowo na odtwarzanie nagrania szybkiego 
procesu w zwolnionym tempie w celu bardziej szczegółowej analizy. 
Dodatkowo, można zdefiniować odtwarzanie zarejestrowanej sekwencji w 
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pętli (Infinitive loop playing) lub odtwarzanie tylko części zaznaczonej. Aby 
zdefiniować zaznaczenie należy ustawić znaczniki położenia na pasku 
czasu. Wszystkie wspomniane ustawienia można też zmienić za pomocą 
paneli sterujących poniżej okna głównego. 

 

 

Uwaga! 
Ustawienia odtwarzania dotyczą tylko bieżącego pliku 
wyświetlanego w oknie głównym. Jednakże wszystkie ustawienia 
można zapisać w indywidualnym szablonie przypisanym do pliku. 

 

Oprogramowanie pozwala 
na późniejszą zmianę 
parametrów pomiarowych. 
Za pomocą menu Tools > 
Configuration > Playing > 
While playing use this 
alternative values and 
settings można ustawić 
parametry emisyjności, temperatury otoczenia i przepuszczalności 
stosowanie do warunków pomiaru. Ponadto, za pomocą opcji Disable 
recorded reference temperature można wyłączyć wartość wzorcową 
zapisaną w pliku. 

5.3. Edycja sekwencji wideo 

Wybrany fragment sekwencji wideo można edytować za pomocą opcji Trim 
to selection i Cut out selection w menu Edit.  

 

Pasek czasu znajduje się w dolnej części obrazu. Znaczniki położenia 
ustawić na pasku czasu w pozycjach określających początek i koniec 
fragmentu sekwencji, który ma być edytowany.  

 

 

 

1 
Niezaznaczona część sekwencji wideo (jasnoszara) zostanie 
usunięta za pomocą opcji Trim to selection. Zaznaczona część 
sekwencji (ciemnoszara) pozostanie nadal. 

1 1 2 
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2 
Zaznaczona część sekwencji wideo (ciemnoszara) zostanie usunięta 
za pomocą opcji Cut out selection. 

5.4. Zapisywanie plików 

5.4.1. Ustawianie częstotliwości ramki podczas zapisu 

Maksymalna częstotliwość ramki kamery 
wynosząca 120Hz może być 
zredukowana. Za pomocą menu Tools > 
Configuration > Recording > Recording 
frame rate można ustawić prędkość 
przechwytywania danych. Typowo 
częstotliwość ramki jest podawana w  Hz (obrazach na sekundę).  

Program otrzymuje z kamery obrazy z pełną częstotliwością ramki. Należy 
więc zdefiniować co zrobić z pomijanymi obrazami przy redukcji 
częstotliwości ramki. Istnieje kilka opcji do wyboru za pomocą Mode: 

Off Częstotliwość wyświetlania wynosi 120Hz. 

Skipping 
Pozostałe obrazy będą pomijane z określoną 
częstotliwością ramki, co oznacza, że dla 10Hz będzie 
wyświetlany co 12-ty obraz. 

Average 
Obrazy będą uśredniane ze zdefiniowaną częstotliwością 
ramki, co oznacza, że dla 10Hz 12 obrazów utworzy jeden 
obraz uśredniony. 

Minimum 
Przykładowo przy 10Hz 12 pojedynczych obrazów utworzy 
jeden obraz składający się z pikseli o najniższej 
temperaturze. 

Maximum 
Przykładowo przy 10Hz 12 pojedynczych obrazów utworzy 
jeden obraz składający się z pikseli o najwyższej 
temperaturze. 

Ext. 
Averaging 

Obrazy będą uśredniane ze zdefiniowaną częstotliwością 
ramki jak również czasem uśredniania, co oznacza, że 
przy 10Hz i 200ms pierwsze dwa z 10 wyjściowych 
obrazów utworzą nowy uśredniony obraz. 
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5.4.2. Ustawianie trybów rejestracji 

W razie potrzeby opcja Recording 
time limit pozwala ustawić limit 
czasu rejestracji w sekundach. Po 
osiągnięciu limitu nagrywanie 
zostaje zatrzymane. 

Po włączeniu opcji Radiometric 
recording są rejestrowane wartości temperatury każdego piksela jak 
również zdefiniowanego obszaru. Strumienie wideo zawierające te 
informacje (pliki RAVI) pozwalają użytkownikom na ich szczegółową 
późniejszą analizę. Ponadto, podczas dokonywania analizy można dodawać 
nowe obiekty i alarmy oprócz tych zarejestrowanych. 

 

 

Uwaga! 
Jeśli opcja Radiometric recording nie jest włączona, sekwencje 
zostaną zapisane jako standardowe pliki AVI zawierające jedynie 
informacje o kolorze. Późniejsza konwersja pliku RAVI na AVI i na 
odwrót jest niemożliwa. 

 

Zaznaczenie opcji Save after recording is stopped spowoduje 
automatyczne zapisanie sekwencji wideo bez żadnych powiadomień. Jeśli 
opcja Play after recording is stopped będzie aktywna, zarejestrowana 
sekwencja zostanie odtworzona automatycznie w głównym oknie. 
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Uwaga! 
Status nagrywania jest wyświetlany w 
dolnym pasku powiadomień. Podczas 
nagrywania kolor tła zmienia się na 
CZERWONY. 

 

5.4.3. Tymczasowy plik rejestracji 

Należy określić katalog do zapisu tymczasowych plików wideo. 

 

 

 

 

 

Uwaga! 
Każda nowa rejestracja nadpisuje poprzednią. 

 

5.4.4. Zapis sekwencji radiometrycznych lub AVI 

Sekwencje wideo mogą być zapisywane jako radiometryczne (RAVI) albo 
nieradiometryczne (AVI). Pliki RAVI zawierają informacje o temperaturze.  

 

 

Uwaga!Uwaga!Uwaga!Uwaga! 

Jeśli opcja Radiometric recording (patrz rozdział 5.4.2) nie jest 
włączona, sekwencje zostaną zapisane jako standardowe pliki AVI 
zawierające jedynie informacje o kolorze. Późniejsza konwersja 
pliku RAVI na AVI i na odwrót jest niemożliwa. 

 

Do zapisywania sekwencji można użyć opcji menu File > Record 
/ Stop albo ikon paska narzędziowego. 

Jeśli sekwencja wideo zawiera oczekiwaną treść, można 
ją zapisać za pomocą menu File > Save albo ikony 
paska narzędziowego. 
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5.4.5. Zapis danych jako radiometrycznego zrzutu obrazu lub pliku 
tekstowego 

 

Zrzuty obrazu są pojedynczymi, radiometrycznymi ramkami 
obrazowymi wyjętymi z sekwencji wideo, co oznacza, że 
posiadają informacje o temperaturze oraz obszarach 
pomiarowych. Dlatego zrzuty obrazów można zawsze 
szczegółowo analizować w późniejszym czasie. 

Zrzuty można przechwytywać za pomocą opcji menu File > Snapshot albo 
za pomocą ikon paska narzędziowego. 

Za pomocą ustawień w menu 
Tools > Configuration > 
Snapshots / Copy to clipboard 
można zdefiniować w jaki sposób 
zrzut obrazu jest kopiowany do 
schowka lub zapisywany w komputerze.  

Zrzut może być zapisywany w rozdzielczości rzeczywistej (Genuine 
resolution) odpowiadającej rozdzielczości kamery 160x120 pikseli (mały 
obraz) albo wraz z informacjami naniesionymi w głównym oknie (Draw 
overlay information). Rozdzielczość obrazu jest oparta na ustawieniach 
zdefiniowanych dla okna głównego (patrz rozdział 0).  

 

Jeśli jest zaznaczona opcja Open 
a file dialog program zawsze 
poprosi o wskazanie lokalizacji, 
nazwy i typu pliku przed 
dokonaniem zrzutu obrazu. 

Po zaznaczeniu opcji Generate filename by template położenie pliku oraz 
nazwa będą generowane za podstawie ustawień dokonanych w menu Tools 
> Configuration > Trig. Recording / Snapshots (patrz rozdział 5.4.6). 

 

 W menu Tools > Configuration > Trig. Recording / Snapshots można 

zdefiniować typ plików dla zrzutów obrazu.  

Opcja Max. triggered snapshots in history window ustala liczbę 
wyświetlanych plików w odddzielnym oknie historii zrzutów Snapshot 
history (patrz rozdział 4.2.1). Jeśli jest aktywna opcja Ignore last snapshot 
for history po przechwyceniu nowego obrazu w oknie historii będą widoczne 
tylko poprzednie zrzuty. 
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Istnieją następujące opcje formatu zapisu obrazów: 

 

JPEG (*.jpg) 
Zapis obrazu (zrzutu) jako plik radiometryczny w 
formacie JPEG.  

TIFF (*.tiff) 
Zapis obrazu (zrzutu) jako plik radiometryczny w 
formacie TIFF. 

Text (Image 
data) (*csv) 

Zapis obrazu (zrzutu) jako plik tekstowy w celu edycji 
informacji w arkuszu Excel. 

Text (Temp. 
profile data) 
(*csv) 

Zapis danych profilu jako plik tekstowy w celu edycji 
informacji w arkuszu Excel. 

 

 

Uwaga!Uwaga!Uwaga!Uwaga! 
Pliki JPEG i TIFF są zapisywane jako radiometryczne i mogą być 
później szczegółowo analizowane za pomocą programu PI 
Connect. Dodatkowo, mogą być też wyświetlane w każdym 
standardowym programie graficznym (np. Photoshop) z informacją 
o kolorze każdego punktu obrazu. 
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Analiza obrazu termicznego w Excelu z wykorzystaniem eksportu do pliku 
*.csv i wyświetlaniem danych pikseli w postaci wykresu 3D. 

 

5.4.6. Zapis pliku tekstowego czasowego przebiegu temperatury 

Za pomocą menu File > Saving temp/time diagram data mozna zapisać 
dane wykresu w pliku tekstowym (*.dat) dla późniejszej analizy. 

 

5.4.7. Położenie i szablony nazw plików wyzwalanych rejestracji 

 

Za pomocą menu Tools > Configuration > Trig. Recording / Snapshots 
można zdefiniować prefix nazwy pliku (Prefix for filename). Program użyje 
tego prefiksu podczas zapisywania sekwencji lub zrzutu. 



TEST-THERM Sp. z o.o., ul.Friedleina 4-6, 30-009 Kraków 

optris PIConnect – PL2011-02-A 

40 

Parametr Path określa położenie wszystkich plików i może być tutaj 
zmienione. Po zarejestrowaniu plik jest zapisywany w tej lokalizacji, pod 
nazwą zawierającą prefiks, bieżącą datę i czas. 

 

 

Uwaga! 
Dzięki opcji Create link na liście „reopen file“ wyzwalanych sekwencji 
wideo o zrzutów obrazów, pliki mogą być łatwo otwierane za pomocą 
menu File > Reopen. 

Przechwytywane dane zawierają wszystkie informacje takie jak 
obszary pomiarowe, i wskaźniki temperatury głównego okna jeśli jest 
zaznaczona opcja Save layout together with triggered video 
sequences and snapshots. 

 

5.4.8. Display of snapshots in a separate window 

W menu View > Windows > Snapshot history można włączyć wyświetlanie 
okna w celu podglądu wszystkich wyzwolonych zrzutów ekranu (patrz też 
rozdział 4.2.1). Wcześniej należy zaznaczyć opcję Generate filename by 
template w menu Tools > Configuration > Trig. Recording / Snapshots 
(patrz rozdział 0). 

 

5.4.9. Zapis obrazów lub zrzutów ekranu do schowka 

Za pomocą menu File > Copy to clipboard lub ikony paska 
narzędziowego obraz z głównego okna można skopiować do 
schowka w celu wklejenia go do innych programów. 
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Alternatywnie, można skopiować do schowka całe okno programu  
(zrzut ekranu) za pomocą menu File > Screenshot > Copy to 
clipboard. 

 

 

Uwaga! 
Całe okno programu można też zapisać za pomoca 
polecenia menu File > Screenshot > Save albo ikony 
paska narzędziowego. 
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6. PRZETWARZANIE DANYCH 

6.1. Obszary pomiarowe 

6.1.1. Ustawienia ogólne 

Obszary pomiarowe do analizy temperatury mogą być definiowane, 
edytowane i usuwane za pomocą menu Tools > Configuration > Measure 
areas. 

 

Za pomocą przycisków New / Delete 
można stworzyć nowy obszar 
pomiarowy (punkt pomiarowy / 
prostokąt) albo usunąć istniejący.  

Naciskać przycisk Up / Down aby 
ustawić kolejność poszczególnych 
obszarów pomiarowych na liście. 

Jeden z obszarów pomiarowych z listy 
może być określony jako główny 
obszar pomiarowy (Main measure 
area). Temperatura głównego obszaru 
pomiarowego może być wyświetlana w 
oknie głównym lub konwertowana na 
sygnał elektryczny wyprowadzany 
przez interfejs procesowy (PIF) 

 

Po zaznaczeniu opcji Show in image obszary pomiarowe będą wyświetlane 
na tle obrazu termicznego. 

Zaznaczenie opcji Show grippers / Show gripper labels pozwala na 
zmianę położenia lub rozmiaru zdefiniowanych obszarów pomiarowych za 
pomocą myszy. 

 

Zaznaczenie opcji Show name at location pozwala na zdefiniowanie 
położenia nazwy przypisanej do danego obszaru (położenie na rysunku). 
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Dostępnymi trybami pomiaru są: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Prostokąt zdefiniowany przez 
użytkownika 

 
Punkt pomiarowy (1x1) 

 
Punkt pomiarowy (3x3) 

 
Punkt pomiarowy (5x5) 

 

Każdy obszar pomiarowy może mieć przypisaną unikalną nazwę 
w polu Name. Opcja Mode umożliwia zdefiniowanie typu obszaru 
jako punkt lub prostokąt. Temperaturę głównego obszaru 
pomiarowego można wyświetlać w głównym oknie. Dostępne typy 
pomiaru to  Minimum, Mean value lub Maximum. Możliwe jest też użycie 
ikony na pasku narzędziowym. 

W sekcji Position można zdefiniować dokładne położenie obszaru 
pomiarowego w oknie głównym. Można też zdecydować czy wybrany obszar 

Position (X, Y) 
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ma reprezentować Hot spot (punkt lub obszar na obrazie o najwyższej 
średniej temperaturze) albo Cold spot (punkt lub obszar na obrazie o 
najniższej średniej temperaturze).  

Przy pomocy przycisku Center można ustawić obszar pomiarowy w środku 
okna głównego, a za pomocą przycisku Standard size rozmiary prostokąta 
przyjmą predefiniowane wartości. 

 

Opcja Bind to temperature profile można 
przypisać każdy z obszarów do jednego z dwóch 
profili temperatury (Profile 1 / Profile 2). 

Położenie obszaru pomiarowego i profilu może być  
określone za pomocą opcji Location [%]. 
Współczynnik wielkości można określić za pomoca 
opcji Min. Size. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Obszar pomiarowy przypisany do profilu (punkt 
pomiarowy) 

 

Obszar pomiarowy przypisany do profilu 
(prostokąt) 
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6.1.2. Wykluczanie obszarów punktów gorących i zimnych 

 

 

 

 

 

 

 

 

 

 

 

 

Za pomocą menu Tools > Configuration > Measure areas > Edit excluded 
areas of hotspots/coldspots można wykluczyć istniejące lub potencjalne 
gorące/zimne punkty z analizy danych. Wewnątrz zdefiniowanych przez 
użytkownika obszarów obrazu punkty nie będą rozpatrywane. Nowy obszar 
można edytować za pomocą przycisku Add a new spot exclude area albo 
usuwać za pomocą przycisku Remove this spot exclude area. Obszary 
wykluczenia można wybierać spośród już istniejących obszarów 
zdefiniowanych przez użytkownika na rozwijanej liście lub określić za 
pomocą współrzędnych. 

Jeśli zostanie zaznaczona opcja Show spot exclude areas obszary zostaną 
pokazane w oknie głównym. 
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6.1.3. Indywidualne wartości emisyjności obszarów pomiarowych 

W razie pomiaru  wielu 
materiałów można ustawić różne 
wartości emisyjności na obrazie. 

Za pomocą menu Tools > 
Configuration > Measure areas 
> Emissivity można określić 
indywidualne emisyjności. 

Wskazania zmian wartości 
temperatury wewnątrz obszarów 
pomiarowych będą nadal 
powiązane z kolorami palety 
barwnej. 
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6.2. Profil temperatury 

Można wygenerować do 2 profili 
temperatury, które graficznie odtworzą 
rozkład temperatury. Profile są 
oznaczane Profile 1 and Profile 2.  

Położenie i rozmiar profili można 
zdefiniować za pomocą współrzędnych 
początku i końca – Begin (P1) i End 

(P2).  

 

Jeśli profile mają być wyświetlane na obrazie termicznym należy 
zaznaczyć opcję Show in image. Alternatywnie ten sposób 
wyświetlania można włączyć za pomocą menu View >  

Image information (patrz rozdział 4.2.3). 

 

 

 

 

 

Położenie i rozmiar profili można też zdefiniować 
przeciągając kursorem myszy uchwyty na 
końcach linii na obrazie w głównym oknie. Aby 
móc tego dokonać należy włączyć opcję Show grippers. Opcja 
Show gripper labels wyświetla współrzędne (punktu 
początkowego P1 i końcowego P2).  
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Profile temperatury mogą być wyświetlane w dodatkowych oknach (patrz 
rozdział 4.2.1). Za pomocą opcji Show in horizontal diagram i Show in 
vertical diagram profile można przyporządkować do poziomego i/lub 
pionowego okna wykresu. 

Opcja Range pozwala na wybór między 
automatycznym a ręcznym skalowaniem 
temperatury na wykresie.  

Istnieją dwa sposoby wyświetlania 
krzywej profilu na wykresie. Za pomocą 
opcji Assign to image krzywa profilu 
wypełnia tylko część odpowiadającą 
rzeczywistej długości profilu na obrazie. 
Za pomocą opcji Full range krzywą 
profilu można wydłużyć tak, aby 
zajmowała całe okno wykresu niezależnie od długości profilu. 

 

 

 

 

 

 

 

Krzywa profilu dopasowana do długości  
profilu (wykres w oddzielnym oknie) 

Krzywa profilu rozciągnięta na całe okno 
(wykres w oddzielnym oknie) 
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Przycisk Bind measure areas to 
profile pozwala na przypisanie 
różnych obszarów pomiarowych do 
profilu temperatury. Jeśli pozycja 
profilu ulegnie zmianie, położenie 
wszystkich obszarów pomiarowych 
również się zmieni. Odpowiedni 
profil można wybrać za pomocą 
opcji Assign measure areas to.  

Parametr Prefix for measure area 
name pozwala na indywidualne 
opisywanie obszarów 
pomiarowych. Typ obszaru 
pomiarowego można zdefiniować 
za pomocą opcji Mode. 

Można też określić liczbę 
obszarów pomiarowych do utworzenia (Number of measure areas to 
create) jak również szerokość w % długości profilu (Width [% of profile 
lenght]) i minimalną wysokość Minimum height [pixels]. 

 

Sekcja Measure mode wyznacza sposób wyświetlania: minimum, maximum 
lub średnia (Mean value) w oknie wyświetlaczy cyfrowych (patrz rozdział 
4.2.1). 

 

Opcja Delete existing measure areas 
of this temperature profile usuwa 
zdefiniowane ustawienia profilu.  

 

Przycisk Create pozwala na utworzenie 
zdefiniowanego profilu. 

 

 

 

3 prostokąty i 3 punkty pomiarowe 
przypisane do profili temperaturowych 
T1 i T2. 
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6.3. Wykres czasowego przebiegu temperatury 

6.3.1. Ustawienia ogólne 

Za pomocą menu 
Tools > Configura-
tion > Temp/Time 
Diagram można 
wyświetlić przebieg 
czasowy temperatury 
dla każdego obszaru 
pomiarowego jak 
również zdefiniowane 
wstępnie parametry  
(patrz rozdział 4.2.4). 

Kolumna Show określa czy dany parametr mierzony ma być wyświetlany na 
wykresie (Graph) czy nie. Opcja Name decyduje czy ma się pojawiać nazwa 
czy nie.  

Włączenie opcji Auto range dla powoduje automatyczne skalowanie 
odpowiedniego wykresu. Jeśli opcja nie jest włączona skalowanie odbywa 
się w oparciu o inne wartości temperatury.  

W kolumnie Pen, opcje Width oraz Color decydują odpowiednio o grubości i 
kolorze linii wykresu. 

 

Dodatkową opcją 
do określenia jest 
minimalna 
szerokość osi czasu w sekundach. Po zaznaczeniu opcji When replaying 
set initial time to length of video szerokość osi czasu jest automatycznie 
dopasowywana do długości załadowanej sekwencji wideo. 
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W ustawieniach wykresu 
(diagram measuring 
settings) można zdefiniować 
maksymalną ilość danych 
(Max. data count) która 
będzie prezentowana na 
wykresie 1.000 x 10.000 
oznacza 10.000.000 (dziesięć 
milionów) wartości 
pomiarowych; wymagana ilość 
pamięci (Memory) będzie 
obliczana automatycznie. 

Za pomocą opcji Auto (device 
framerate) czas rejestracji 
Recording time jest obliczany w oparciu o częstotliwość ramki kamery 
(patrz rozdział 5.4.1).  

Niezależnie od częstotliwości ramki kamery można indywidualnie ustawić 
ilość danych. Po wybraniu opcji User defined można wpisać w polu 
Diagram resolution okres aktualizacji danych. Za pomocą strzałek można 
go zwiększać lub zmniejszać.  

 

6.3.2. Skalowanie osi wykresu 
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Elementy sterujące osi czasu 

 

1 Suwak do przesuwania osi czasu. 

2 Powiększanie osi czasu. Oś temperatury pozostaje bez zmian. 

3 Pomniejszanie osi czasu. Oś temperatury pozostaje bez zmian. 

4 
Cały zakres: wyświetlenie całej osi czasu, np. zapisanej sekwencji 
wideo. 

5 

H: Hold / C: Kontynuacja: Każde użycie elementu sterującego H 

zatrzymuje dalszą aktualizację wykresu. Pomiary są kontynuowane 
w tle. Aby powrócić do aktualnego stanu wykresu należy nacisnąć 

element sterujący C. 

Podczas zatrzymania można oglądać dowolną część wykresu. Za 
pomocą przycisków powiększania/pomniejszania. 

 

Elementy sterujące osi temperatury 

 

6 
Skalowanie globalne: zakres temperatury wykresu będzie się 
automatycznie dopasowywał do odpowiednich wartości skrajnych. 
Zmiany podążają zawsze w stronę rozszerzania zakresu. 

7 

Skalowanie lokalne: zakres temperatury wykresu będzie się 
automatycznie dopasowywał do odpowiednich wartości skrajnych. 
Po opuszczeniu pola wykresu przez wartości szczytowe, zakres 
zostaje znów przeliczony. Ta opcja pozwala na optymalne 
wyświetlanie wykresu temperatury. 

8 Suwak do przesuwania osi temperatury. 

9 Powiększanie osi temperatury. Oś czasu pozostaje bez zmian. 

10 Pomniejszanie osi temperatury. Oś czasu pozostaje bez zmian. 

11 Cały zakres: wyświetlenie całego zakresu pomiarowego kamery. 
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6.4. Histogram 

Funkcja Histogram pokazuje rozkład 
wartości temperatury pikseli na obrazie 
termicznym. Oś pozioma histogramu 
reprezentuje przedziały temperatur a oś 
pionowa procentowy udział pikseli o 
temperaturze przynależącej do danego 
przedziału temperatur.  

W menu Tools > Configuration > 
Histogram można dokonać ustawień 
różnych parametrów. Dany zakres 
temperatury Temperature range oraz 
ilości Quantity range może być 
wygenerowany przez program albo ustalony przez użytkownika przez 
podanie wartości granicznych min/max. 

 

 

 

 

 

 

Dalszymi opcjami są: 

 

Display current 
temperature 

Po włączeniu tej opcji czerwona linia będzie 
wskazywać aktualną temperaturę kursora na 
wykresie. 

Display mean 
and sigma value:    

Włącza wyświetlania temperatury średniej oraz 
odchylenia statystycznego σ. 

Use palette 
colors 

Włączenie prezentacji wykresu z użyciem palety 
barwnej zamiast jednego koloru. 

Class size 
Liczba wartości pomiarowych które powinny być 
przyłączone do jednej klasy dla wyświetlenia 
wspólnym kolorem. 
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6.5. Rozszerzone kolory pomiarowe 

Menu Tools > 
Configuration > 
Measuring colors > 
Extended Measuring 
colors oferuje 
możliwość zmiany 
barw pikseli na obrazie 
kiedy temperatura 
osiąga zdefiniowane 
granice zakresu. 
Dokonując tego można 
wizualizować gradienty 
temperatury. 
Dodatkowo, jest 
możliwe wyświetlanie 
izoterm (zamalowanie 
kolorem pewnych grup 
temperatur). 

Za pomocą progów 
(Threshold) można ustalić dwie wartości temperatury. Można zdefiniować 
niezależne ustawienia kolorów pikseli leżących powyżej (High), pomiędzy 
(Mid) lub poniżej (Low) progów za pomocą izoterm (Color) albo 
alternatywnej palety barw (Alt. Palette).  

Używając palety alternatywnej 
(Alt. palette) kolory odpowiadają 
granicom temperatury palety. 
Widoczny będzie zakres palety 
zdefiniowanej progami.  

Za pomocą palety alternatywnej 
rozszerzonej (Ext. Alt. Palette) 
można indywidualnie określić 
punkt początkowy i końcowy 
palety alternatywnej wewnątrz  
palety całkowitej. 
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6.6. Odejmowanie obrazów 

Jeśli ta funkcja została włączona za pomocą menu Device > 
Image subtraction albo ikony paska narzędziowego, obraz
zapisywane w tle i dla wszystkich kolejnych obrazów jest obliczana 
i wyświetlana różnica temperatur.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Alternatywnie, można załadować uprzednio zapisany obraz 
radiometryczny (.jpg lub .tiff) wykorzystując polecenie menu 
Devices > Image subtraction from file lub ikonę na pasku 
narzędziowym, w celu użycia go jako szablon dla odejmowania 
obrazów. 

 

 

Odejmowanie obrazów wyłączone. 

W prawym górnym rogu jest wyświetlana 
uśredniona obszaru pomiarowego. 

Po włączeniu funkcji 
wyświetlana jest aktualna różnica 
temperatur w porównaniu do poprzedniego 
obrazu. 

therm.pl 
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Device > 
obraz jest 

zapisywane w tle i dla wszystkich kolejnych obrazów jest obliczana 

można załadować uprzednio zapisany obraz 
wykorzystując polecenie menu 

lub ikonę na pasku 
narzędziowym, w celu użycia go jako szablon dla odejmowania 

Po włączeniu funkcji odejmowania obrazów 
wyświetlana jest aktualna różnica 
temperatur w porównaniu do poprzedniego 
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6.7. Względne wartości ektremalne 

Za pomocą menu Tools > Configuration > Extended measurement 
możliwe jest wykluczenie części pikseli obrazu termicznego z analizy 
danych. Za pomocą opcji Ignore pixels with temperatures można określić 
dolną (below) i górną (above) granicę temperatury.  

 

W przypadku analizy obrazu z wykorzystaniem obszarów pomiarowych, 
zaznaczenie opcji for measure areas spowoduje, że podczas obliczania 
parametrów wynikowych (np. średniej temperatury) nie będą uwzględniane 
temperatury powyżej i poniżej określonych granic.  

 

Opcja for hot/cold spots localization powoduje wykluczenie określonych 
stref temperatury z wyszukiwania punktów najcieplejszych / 
najchłodniejszych.  

 

Opcja for </> temperature ranging powoduje wykluczenie określonych stref 
temperatury z wpływania na automatyczne ustalanie zakresów temperatury 
dla wykresów. 
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6.8. Alarmy 

Za pomocą menu Tools > Configuration > Alarms można 
zdefiniować alarm dla każdego skonfigurowanego obszaru 
pomiarowego jak i wielkości predefiniowanych (patrz rozdział 4.2.4).  

 

Wartości alarmowe mogą być wyświetlane 
cyfrowo na wskaźnikach cyfrowych innym 
kolorem albo w postaci bargrafów. W celu 
uzyskania tych ostatnich należy zaznaczyć 
opcję Show Graph Bar. Zakresy 
bargrafów są definiowane wartościami min 
i max w kolumnie Display ranges (granice 
temperatury). Wartości progowe alarmów 
Alarms Low i High określają poziomy 
temperatur zmieniające barwy wskaźników na 
alarmowe. 

Gdy zostanie osiągnięta lub przekroczona 
wartość alarmu górnego kolor bargrafu i cyfr 
zmienia się na czerwony. Gdy mierzona 
temperatura osiąga lub spada poniżej alarmu dolnego  kolor bargrafu i cyfr 
zmienia się na niebieski. Dla temperatur pomiędzy granicami alarmów 
bargraf jest wyświetlany w kolorze zielonym.  

 

 

Uwaga! 
Po osiągnięciu wartości alarmowej kolor cyfry/bargrafu zmienia się z 
zielonego na czerwony (górny alarm) lub niebieski (dolny alarm). 
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Jeśli wartość temperatury ma być używana do sygnalizacji alarmu, należy 
dokonać zaznaczenia w kolumnie Alarm. W razie potrzeby, sygnał alarmu 
można też wyprowadzić na wyjście interfejsu procesowego (PIF) 
zaznaczając opcję Alarm to PIF.  

 

 

Uwaga! 

W razie wystąpienia alarmu na pasku narzędziowym pojawia się 
przycisk alarmu. Klikając go można skasować alarm akustyczny i 
wizualny. Alarm będzie skasowany aż do pojawienia się nowego. 

 

W oknie konfiguracji alarmu można ustawić alarm 
akustyczny zaznaczając opcję Enable.  

 

W polu Interval [sec] należy wprowadzić okres czasu powtarzania dźwięku 
alarmowego. Za pomocą pola Path to sound file można wskazać ścieżkę 
do pliku zawierającego dźwięk alarmu w formacie *.wav. 

 

W sekcji Recording on alarm można włączyć funkcję rejestracji sekwencji w 
momencie wystąpienia alarmu (Enable). Można też określić opóźnienie 
rozpoczęcia rejestracji za pomocą parametru Delay [sec]. Rejestracja 
rozpocznie się po upływie czasu opóźnienia. Parametrem Duration [sec] 
można określić czas trwania nagrywania.  

 

Dodatkowo, rejestrację można zatrzymać w razie zaniknięcia alarmu po 
zaznaczeniu opcji Abort recording if alarm condition drops out. Gdyby ta 
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opcja nie była zaznaczona, nagranie potrwa tyle ile wynosi ustawiony limit 
czasu. 

 

W sekcji Snapshot on alarm można włączyć funkcję zapisywania zrzutu 
obrazu w razie wystąpienia alarmu (Enable) oraz określić opóźnienie 
działania Delay [sec]. 
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7. TRYB SKANERA LINIOWEGO 

7.1. Informacje ogólne 

Oprogramowanie PI Connect 
jest wyposażone w funkcję  
skanera liniowego. Tryb skanera 
liniowego jest zazwyczaj 
używany w procesach ciągłych z 
ruchomymi obiektami testowymi, 
takich jak pomiary pieców 
obrotowych, tunelowych czy 
obróbka wsadowa z 
wykorzystaniem przenośników 
taśmowych. 

 

Przegląd zalet: 

 

1. Prosty monitoring procesu 
przy ograniczonym dostępie 
optycznym 

2. Pośrednia wizualizacja 
rozkładu temperatury w 
piecu poprzez instalację 
kamery na wylocie pieca 

3. Rozszerzenie liczby pikseli ze 160 do 200 przez użycie przekątnej 
obrazu 

4. Zapisywanie nieograniczonej liczby linii z częstotliwością 120Hz, co w 
rezultacie daje obrazy termiczne o dowolnej rozdzielczości  

5. Kąt widzenia linii 60° dla szczegółowej analizy procesu nawet na 
szerokich taśmach przenośników 
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7.2. Ustawienia podstawowe 

7.2.1. Menu konfiguracji skanera liniowego 

Wszystkie ustawienia związane ze skanerem liniowym mogą być 
dokonane za pomocą menu konfiguracji skanera liniowego. Menu 
znajduje się w  Tools > Linescanner mode > Linescanner 
settings albo ikona na pasku narzędziowym. 

 

7.2.2. Wybór szablonu 

Przed skonfigurowaniem trybu skanera liniowego należy wybrać lub stworzyć 
odpowiedni szablon strony (np. ułożenie okien aplikacji). Więcej na ten temat 
można znaleźć w rozdziale 4.2. 

 

7.2.3. Obrót obrazu 

Dla niektórych zastosowań dużą zaletą 
jest możliwość zwiększenia liczby pikseli 
na linię ze 160 do 200 przez zmianę 
kąta patrzenia. Aby tego dokonać 
należy przejść do sekcji Rotate (patrz 

rozdział 4.3.2) 

 

Stosownie do wybranego kąta patrzenia 
kamery należy ją usytuować względem 
obserwowanego procesu. 
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7.2.4. Włączanie skanera liniowego 

W celu skonfigurowania skanera należy włączyć tryb skanera 
liniowego w Tools > Linescanner mode > Enable Linescanner 
albo za pomocą ikony paska narzędziowego. 

 

 

Uwaga! 

Dostępne są dwie opcje widoku w trybie skanera liniowego. 
Linescanner sighting view – pokazuje położenie linii oraz strefy 
samowyzwalania na obrazie termicznym obejmowanym przez 
kamerę (tryb podglądu). Linescanner view – dostarcza wynikowego 
obrazu termicznego w oparciu o odczyt temperatury dla wybranych 
linii (tryb skanera).  

 

7.2.5. Pozycjonowanie linii (tryb podglądu) 

Zdefiniowane położenie linii jest widoczne w trybie podglądu (Linescanner 
sighting view). Aby włączyć ten widok należy użyć polecenia Tools > 
Linescanner mode > Linescanner sighting albo kliknąć odpowiednią 
ikonę. 

 

 

Uwaga! 

Ta ikona służy do przełączania widoków Linescanner 
sighting view i Linescanner view. 

 

Aby zdefiniować położenie linii na obrazie 
termicznym należy przejść do okna konfiguracji 
skanera liniowego (patrz rozdział 7.2.1) w menu 
Source. W sekcji Lines taken from source za 
pomocą pól First row i Last row można określić 
ile linii będzie brane pod uwagę podczas pomiaru. Liczba 1 oznacza 
pierwszą linię od góry na obrazie termicznym. 

Jeśli więcej niż jedna linia ma być brana pod 
uwagę ze źródła, w sekcji Direction można 
określić kierunek w którym będzie zachodzić 
skanowanie i kreślony będzie obraz w 
podglądzie Linescanner sighting view. 
Można wybrać jeden z 4 kierunków: góra-dół 
(Scan top-down), dół-góra (Scan bottom-
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up), lewo-prawo (Scan left to right) lub prawo-lewo (Scan right to left). 

 

 

 

 

 

 

 

Wyświetlane widoki podglądu skanera pokazują 4 możliwości 
przechwytywania. 

 

7.2.6. Konfiguracja szablonu w trybie podglądu 

Dalsze modyfikacje można wykonać w trybie podglądu za pomocą menu 
rozszerzonego (Extended). W sekcji Sighting view można zdefiniować 
następujące modyfikacje widoku: pokazanie źródłowych linii skanujących 
(Show source scanning lines), pokazanie obszaru samowyzwalania 
(Show self triggering area) ukrycie wszystkich okien narzędzi (Hide all tool 
windows).  

 

Opcja Alternative temperature range for sighting view pozwala włączyć 
inny zakres temperatury niż ten używany podczas pomiarów. Czasem 
wygodnie jest skonfigurować skaner gdy proces jest zatrzymany przy użyciu 
innego zakresu pomiarowego w celu przetestowania działania.   
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7.3. Przetwarzanie skanowanych danych 

7.3.1. Widok skanera liniowego  

W widoku skanera linowego jest wyświetlany zeskanowany obraz  
termiczny. Aby włączyć ten widok należy się posłużyć 
przewidzianą do tego celu ikoną. 

 

 

Uwaga! 

Ta ikona służy do przełączania widoków skanera 
liniowego i podglądu skanera liniowego. 

 

Prezentacja zeskanowanych linii może być dodatkowo zdefiniowana w  oknie 

konfiguracji skanera liniowego (patrz rozdział 7.2.1) w sekcji Presentation. 

Opcja Direction definiuje kierunek w którym będą wyświetlane skanowane 
linie. Mogą to być kierunki góra-dół (Top-down), dól-góra (Bottom-up), 
lewo-prawo (Left to right) lub prawo-lewo (Right to left).  

 

 
Prezentacja skanowanych linii w widoku skanera liniowego: 

góra-dół, dół-góra, lewo-prawo i prawo-lewo. 

 

Parametrem Lines można określić 
ile linii będzie wyświetlanych w 
widoku skanera. Liczba linii 
definiuje też po ilu liniach obraz 
termiczny zostanie przeładowany. 

Pole History [sec] określa okres czasu z jakiego są wyświetlane 
zeskanowane linie. Czas ten może być oparty na czasie trwania 
obserwowanego cyklu. Po zaznaczeniu opcji Auto sync wartość zostanie 
określona automatycznie za pomocą zewnętrznego wyzwalania (patrz 
rozdział 7.3.2). W polu Resulting linerate (Hz) pojawi się automatycznie 
obliczona częstotliwość skanowania każdej linii. 
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Opcja Keep aspect ratio ustali szerokość każdej linii tak, aby wszystkie linie 
zmieściły się na ekranie obrazu termicznego. 

 

7.3.2. Wyzwalane wyświetlanie linii 

Sygnał wyzwalający może być używany do 
sterowania sposobem układania linii w widoku 
skanera liniowego. W konfiguracji skanera na 

zakładce General (patrz rozdział 7.2.1) istnieją dwie 

opcje wyzwalania.  

 

Tryb ciągły Continuous egzekwuje predefiniowane wartości wyświetlania 
zeskanowanych linii. Do sterowania prezentacją skanowanych linii nie będzie 
wykorzystywany żaden sygnał.   

 

Opcja External triggered pozwala na użycie zewnętrznego sygnału 
wyzwalającego grupowanie skanowanych linii. Liczba linii skanowanych po 
odebraniu sygnału jest zdefiniowana parametrami Lines i History [sec] 
(patrz rozdział 7.3.1). 

 

Można określić ustawienia dodatkowe:  

W sekcji Flag operation włączenie opcji Avoid 
during scan before auto-snapshots zabrania 
używania flagi podczas skanowania (patrz 
rozdział 4.4.2).  

 

Włączeni opcji Avoid re-triggering during 
scan zabrania uruchomienia nowego cyklu 
skanowania gdy poprzedni cykl nie został 
zakończony. 

 

 

 

Uwaga! 

Przy skanowaniu z wyzwalaniem zewnętrznym konieczne jest 
dokonanie modyfikacji standardowych ustawień interfejsu 
procesowego (PIF). Więcej szczegółów zawiera rozdział 4.5. 
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Przy wykorzystywaniu opcji samowyzwalania (Self triggered) możliwe jest 
używanie sygnału wyzwalającego generowanego programowo. Liczba linii 
skanowanych po sygnale wyzwalania jest określona parametrami Lines i 
History [sec] (patrz rozdział 7.3.1). Możliwe jest dokonanie dodatkowych 
ustawień: 

 

Przede wszystkim należy określić 
obszar wyzwalania (Trigger area) 
wewnątrz obrazu termicznego. 
Parametrami Left, Right, Top i 
Bottom należy wyznaczyć krawędź 
odpowiednio: lewą, prawą górną i dolną obszaru 
prostokąta. Przełączyć na widok podglądu 
skanera liniowego aby zobaczyć wizualizację 
obszaru wyzwalania.  

 

 

 

W sekcji Trigger thresholds należy 
określić dolną (Trigger if below) i/lub 
górną (Trigger if above) wartość progową 
temperatury, które będą wyzwalać cykl 
skanowania liniowego. Holdoff time [s] 
określa ramę czasową wewnątrz której 
nowy sygnał powinien być lekceważony (np. jeśli sygnał ze źródła ciepła w 
tle powoduje wyzwalanie). 

 

W sekcji Flag operation można zabronić 
używania flagi podczas skanowania (Avoid 
during scan can) (patrz też rozdział 4.4.2) lub 
wymusić jej użycie po skanowaniu (Force after 
scan). 
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7.3.3. Konfiguracja zrzutów obrazu 

Aby udokumentować pomiary 
kompletne skany mogą być 
zapisywane w formie zrzutów 
obrazu. W sekcji Auto snapshots 
ustawień skanera liniowego (patrz 
rozdział 7.2.1) znajdują się odpowiednie opcje konfiguracyjne. 

Za pomocą opcji Do snapshots any/ można określić co ile skanów ma być 
dokonywany zapis zrzutu obrazu. Zaznaczając opcję Do snapshots with 
complete linescans only można zakazać zapisywania skanów, które 
zostały przerwane w czasie ich wykonywania. 
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8. INFORMACJE DODATKOWE 

8.1. Włączanie komunikatów 

W pewnych miejscach 
pojawiają się komunikaty 
ostrzegawcze, gdy jest 
wykonywana operacja, 
która może spowodować 
zmianę ustawień. 

 

Aby uchronić się od 
niezamierzonych zmian 
można włączyć lub 
wyłączyć te komunikaty za pomocą menu Tools > Extended > Options. 

 

 

Uwaga! 
W razie pojawienia się komunikatu można go zablokować klikając 
Never ask me again.  

Za pomocą menu Tools > Extended > Options można ponownie 
odblokować zablokowany wcześniej komunikat. 

 

Ważnymi opcjami są: 

Warning if 
unsaved data 
exists 

W razie włączenia tej opcji pojawia się przypomnienie 
ostrzegające o niezapisanych danych lub ustawieniach 
podczas zamykania programu. 

Ask for keeping 
measuring 
objectsI 

Za pomocą tej opcji można wybrać czy ma się 
pojawiać monit o utrzymanie pozycji stworzonych 
obszarów pomiarowych i profili w razie obrotu lub 
powiększenia obrazu. Po obróceniu lub powiększenie 
obszary pomiarowe i profile temperatury nie będą 
odniesione do starych pozycji na obrazie. Mogą być 
jednak utrzymane w razie zresetowaniu obrazu. 

Ask for stopping 
triggered 
recordingsI 

Ta opcja powoduje pojawianie się przy otwarciu 
dialogu konfiguracyjnego pytania o zatrzymanie 
przechwytywania wyzwalanych nagrań. Komunikat ma 
na celu ochronę przed przypadkową zmianą ustawień 
wyzwalania. 
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8.2. Wymagania systemowe 

Minimalne wymagania systemowe: 

� Windows XP (Service Pack 3) 

� Interfejs USB 2.0 

� Dysk twardy posiadający co najmniej 30MB wolnego miejsca 

� Przynajmniej 256MB RAM 

� Napęd optyczny  

 

Zalecane wymagania systemowe: 

� Windows 7 

� Przynajmniej 2GB wolnego miejsca na dysku dla nagrań wideo IR 

� Przynajmniej 2GB RAM 

 

8.3. O programie 

W menu Help > About znajdują się informacje o numerze wersji aktualnie 
uruchomionego programu PI Connect. 
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8.4. Przegląd skrótów klawiaturowych 

F1 Zapis zrzutu obrazu 

Alt+F1 Kopiowanie zrzutu obrazu do schowka 

F2 Nagrywanie 

F3 Stop 

Alt+F4 Wyjście 

F5 Odświeżenie flagi 

F6 Zapis zrzutu ekranu 

Alt+F6 Kopiowanie zrzutu ekranu do schowka 

F10 Potwierdzenie alarmu 

Alt+P Następna paleta 

Ctrl+Alt+P Poprzednia paleta 

Alt+Enter Pełny ekran 

Alt+S Odejmowanie obrazów 

Alt+H Odbicie lustrzane poziome 

Alt+V Odbicie lustrzane pionowe 

Ctrl+Alt+S Odejmowanie obrazów z pliku 

Ctrl+L Widok podglądu skanera liniowego 

Ctrl+Alt+L Włączenie skanera liniowego 
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